We identified issues affecting our US CDN infrastructure and applied mitigation actions. Services are currently recovering, and we are actively monitoring performance and stability.
Some users may still experience intermittent playback issues or increased latency while recovery completes.
Our team will continue monitoring closely and provide further updates if necessary.
Posted May 26, 2026 - 02:22 GMT-04:00
Investigating
We are currently experiencing issues affecting our US CDN infrastructure. Some users may encounter intermittent playback problems, increased latency, or difficulties accessing content.
Our engineering team is actively investigating the situation and working with the provider to restore normal service as quickly as possible.
We will continue to provide updates as more information becomes available.
Posted May 26, 2026 - 00:36 GMT-04:00
This incident affected: CDN (Origin US, Edges Node US).